jupyterlab_sparkmonitor-s

v1.0.0

Jupyter Lab extension to monitor Apache Spark Jobs

Apache-2.0
Latest version published 3 months ago
    npm install jupyterlab_sparkmonitor-s
  

Package Health Score

23 / 100
  • Popularity
    Limited
  • Maintenance
    Inactive
  • Security
    Security issues found
  • Community
    Limited

Popularity

Limited
Weekly Downloads (15)
Dependents
0
GitHub Stars
33
Forks
7
Contributors
4

The npm package jupyterlab_sparkmonitor-s receives a total of 15 downloads a week. As such, we scored jupyterlab_sparkmonitor-s popularity level to be Limited.

Based on project statistics from the GitHub repository for the npm package jupyterlab_sparkmonitor-s, we found that it has been starred 33 times, and that 0 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

Security issues found

Security and license risk for recent versions


Direct Vulnerabilities

0.0.1
0.0.2
0.0.3
0.0.4
1.0.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

0.0.1
0.0.2
0.0.3
0.0.4
1.0.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

0.0.1
0.0.2
0.0.3
0.0.4
1.0.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Snyk detected that the latest version of jupyterlab_sparkmonitor-s has a security vulnerability.

We highly advise you to review these security issues.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like jupyterlab_sparkmonitor-s is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test jupyterlab_sparkmonitor-s
Fix it in your project with Snyk!

Maintenance

Inactive
Commit Frequency
Open Issues
7
Merged PR
6
Open PR
0
Last Commit
3 months ago

Further analysis of the maintenance status of jupyterlab_sparkmonitor-s based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

We found that jupyterlab_sparkmonitor-s demonstrates a positive version release cadence with at least one new version released in the past 3 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Limited
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
4
Funding
No
License
Apache-2.0

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like jupyterlab_sparkmonitor-s is missing a Code of Conduct.

Package

Node.js Compatibility
not defined

Age
3 months
Dependencies
19 Direct / 818 Total
Versions
3
Install Size
335 kB
Dist-tags
1
# of Files
34
Maintainers
1
TS Typings
No

We detected a total of 818 direct & transitive dependencies for jupyterlab_sparkmonitor-s. See the full dependency tree of jupyterlab_sparkmonitor-s

jupyterlab_sparkmonitor-s has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.