hast-to-hyperscript

v10.0.1

hast utility to transform to something else (react, vue, etc) through a hyperscript DSL

MIT
Latest version published 2 months ago
    npm install hast-to-hyperscript
  

Package Health Score

78 / 100

Popularity

Influential project

Weekly Downloads (2,425,511)

Download trend
Dependents
34
GitHub Stars
35
Forks
16
Contributors
10

Direct Usage Popularity

TOP 30%

The npm package hast-to-hyperscript receives a total of 2,425,511 downloads a week. As such, we scored hast-to-hyperscript popularity level to be Influential project.

Based on project statistics from the GitHub repository for the npm package hast-to-hyperscript, we found that it has been starred 35 times, and that 34 other projects in the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues
Powered by Snyk

Security and license risk for significant versions

All Versions
Popular

Version

Release Date

11/2018
11/2019
05/2020
10/2020
07/2021

Direct Vulnerabilities

6.0.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
7.0.4
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
8.1.1
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
Popular
9.0.1
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
10.0.1
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

6.0.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
7.0.4
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
8.1.1
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
Popular
9.0.1
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
10.0.1
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L

License Risk

6.0.0
  • 0
    H
  • 0
    M
  • 0
    L
7.0.4
  • 0
    H
  • 0
    M
  • 0
    L
8.1.1
  • 0
    H
  • 0
    M
  • 0
    L
Popular
9.0.1
  • 0
    H
  • 0
    M
  • 0
    L
10.0.1
  • 0
    H
  • 0
    M
  • 0
    L
All security vulnerabilities belong to production dependencies of direct and indirect packages.

License
MIT

Security Policy
No

We found a way for you to contribute to the project! Looks like hast-to-hyperscript is missing a security policy.


You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

    # Install the Snyk CLI and test your project
npm i snyk -g && snyk test hast-to-hyperscript
Keep your project free of vulnerabilities with Snyk

Maintenance

Healthy

Commit Frequency

Open Issues
0
Open PR
0
Last Release
2 months ago
Last Commit
2 months ago

Further analysis of the maintenance status of hast-to-hyperscript based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Healthy.

We found that hast-to-hyperscript demonstrates a positive version release cadence with at least one new version released in the past 3 months.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Community

Limited
Readme.md
Yes
Contributing.md
No
Code of Conduct
Yes
Contributors
10
Funding
Yes

This project has seen only 10 or less contributors.


Embed Package Health Score Badge

package health: 78/100 package health 78/100

Package

Node.js Compatibility
not defined

Age
5 years
Dependencies
7 Direct
Versions
27
Install Size
20.9 kB
Dist-tags
1
# of Files
5
Maintainers
2
TS Typings
Yes

hast-to-hyperscript has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.