hapi-error

v3.0.0

catch errors in your hapi application and display the appropriate error message/page For more information about how to use this package see README

Latest version published 7 months ago
License: BSD-3-Clause

Ensure you're using the healthiest npm packages

Snyk scans all the packages in your projects for vulnerabilities and provides automated fix advice

Package Health Score

64 / 100

Explore Similar Packages

Security

No known security issues
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Security and license risk for significant versions

All Versions
Version Vulnerabilities License Risk
3.0.0 | 06/2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
2.3.1 | 06/2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
1.8.0 | 07/2017
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
0.0.1 | 04/2016
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
License
BSD-3-Clause
Security Policy
No

Is your project affected by vulnerabilities?

Scan your projects for vulnerabilities. Fix quickly with automated fixes. Get started with Snyk for free.

Get started free

Popularity

Small

Weekly Downloads (1,633)

Download trend
GitHub Stars
75
Forks
12
Contributors
20

Direct Usage Popularity

TOP 30%

The npm package hapi-error receives a total of 1,633 downloads a week. As such, we scored hapi-error popularity level to be Small.

Based on project statistics from the GitHub repository for the npm package hapi-error, we found that it has been starred 75 times.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Community

Sustainable
Readme.md
Yes
Contributing.md
Yes
Code of Conduct
No
Contributors
20
Funding
No

With more than 10 contributors for the hapi-error repository, this is possibly a sign for a growing and inviting community.

We found a way for you to contribute to the project! Looks like hapi-error is missing a Code of Conduct.


Embed Package Health Score Badge

package health: 64/100 package health 64/100

Maintenance

Inactive

Commit Frequency

Open Issues
1
Open PR
1
Last Release
7 months ago
Last Commit
7 months ago

Further analysis of the maintenance status of hapi-error based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

We found that hapi-error demonstrates a positive version release cadence with at least one new version released in the past 12 months.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Package

Node.js Compatibility
>=14.0.0

Age
7 years
Dependencies
1 Direct
Versions
27
Install Size
44 kB
Dist-tags
1
# of Files
19
Maintainers
1
TS Typings
No

hapi-error has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.