gatsby-plugin-advanced-sitemap

v2.1.0

Advanced plugin for generating configurable XML sitemaps with linked media for better SEO and human-readable XSL templates. For more information about how to use this package see README

Latest version published 6 months ago
License: MIT

Ensure you're using the healthiest npm packages

Snyk scans all the packages in your projects for vulnerabilities and provides automated fix advice

Package Health Score

70 / 100

Security

Security review needed
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Security and license risk for significant versions

All Versions
Version Vulnerabilities License Risk
2.1.0 | 03/2022
Popular
  • 0
    H
  • 0
    M
  • 0
    L
2.0.0 | 05/2021
  • 0
    H
  • 0
    M
  • 0
    L
1.6.0 | 02/2021
  • 0
    H
  • 0
    M
  • 0
    L
1.5.7 | 01/2021
  • 0
    H
  • 0
    M
  • 0
    L
1.4.5 | 10/2019
  • 0
    H
  • 0
    M
  • 0
    L
License
MIT
Security Policy
No

Is your project affected by vulnerabilities?

Scan your projects for vulnerabilities. Fix quickly with automated fixes. Get started with Snyk for free.

Get started free

Popularity

Recognized

Weekly Downloads (22,291)

Download trend
Dependents
33
GitHub Stars
146
Forks
52
Contributors
20

Direct Usage Popularity

TOP 30%

The npm package gatsby-plugin-advanced-sitemap receives a total of 22,291 downloads a week. As such, we scored gatsby-plugin-advanced-sitemap popularity level to be Recognized.

Based on project statistics from the GitHub repository for the npm package gatsby-plugin-advanced-sitemap, we found that it has been starred 146 times, and that 33 other projects in the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Community

Active
Readme.md
Yes
Contributing.md
Yes
Code of Conduct
No
Contributors
20
Funding
Yes

With more than 10 contributors for the gatsby-plugin-advanced-sitemap repository, this is possibly a sign for a growing and inviting community.

We found a way for you to contribute to the project! Looks like gatsby-plugin-advanced-sitemap is missing a Code of Conduct.


Embed Package Health Score Badge

package health: 70/100 package health 70/100

Maintenance

Sustainable

Commit Frequency

Open Issues
16
Open PR
14
Last Release
6 months ago
Last Commit
1 month ago

Further analysis of the maintenance status of gatsby-plugin-advanced-sitemap based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Sustainable.

We found that gatsby-plugin-advanced-sitemap demonstrates a positive version release cadence with at least one new version released in the past 12 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Package

Node.js Compatibility
>= 12.19.0

Age
4 years
Dependencies
6 Direct
Versions
30
Install Size
90.2 kB
Dist-tags
1
# of Files
54
Maintainers
1
TS Typings
No

gatsby-plugin-advanced-sitemap has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.