eslint-plugin-prefer-let

v3.0.1

Rule to prefer using `let` to bind names to values

ISC
Latest version published 1 month ago
    npm install eslint-plugin-prefer-let
  

Package Health Score

78 / 100

Popularity

Recognized

Weekly Downloads (23,869)

Download trend
Dependents
195
GitHub Stars
3
Forks
3
Contributors
20

Direct Usage Popularity

TOP 30%

The npm package eslint-plugin-prefer-let receives a total of 23,869 downloads a week. As such, we scored eslint-plugin-prefer-let popularity level to be Recognized.

Based on project statistics from the GitHub repository for the npm package eslint-plugin-prefer-let, we found that it has been starred 3 times, and that 195 other projects in the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues
Powered by Snyk

Security and license risk for significant versions

All Versions
Popular

Version

Release Date

09/2016
09/2016
09/2020
10/2021
11/2021

Direct Vulnerabilities

0.0.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
0.1.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
Popular
1.1.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.0.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
3.0.1
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

0.0.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
0.1.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
Popular
1.1.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
2.0.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
3.0.1
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L

License Risk

0.0.0
  • 0
    H
  • 0
    M
  • 0
    L
0.1.0
  • 0
    H
  • 0
    M
  • 0
    L
Popular
1.1.0
  • 0
    H
  • 0
    M
  • 0
    L
2.0.0
  • 0
    H
  • 0
    M
  • 0
    L
3.0.1
  • 0
    H
  • 0
    M
  • 0
    L
All security vulnerabilities belong to production dependencies of direct and indirect packages.

License
ISC

Security Policy
No

We found a way for you to contribute to the project! Looks like eslint-plugin-prefer-let is missing a security policy.


You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

    # Install the Snyk CLI and test your project
npm i snyk -g && snyk test eslint-plugin-prefer-let
Keep your project free of vulnerabilities with Snyk

Maintenance

Healthy

Commit Frequency

Open Issues
5
Open PR
4
Last Release
1 month ago
Last Commit
7 days ago

Further analysis of the maintenance status of eslint-plugin-prefer-let based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Healthy.

We found that eslint-plugin-prefer-let demonstrates a positive version release cadence with at least one new version released in the past 3 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Limited
Readme.md
Yes
Contributing.md
No
Code of Conduct
Yes
Contributors
20
Funding
No

With more than 10 contributors for the eslint-plugin-prefer-let repository, this is possibly a sign for a growing and inviting community.


Embed Package Health Score Badge

package health: 78/100 package health 78/100

Package

Node.js Compatibility
>=0.10.0

Age
5 years
Dependencies
1 Direct
Versions
21
Install Size
5.51 kB
Dist-tags
10
# of Files
8
Maintainers
3
TS Typings
No

eslint-plugin-prefer-let has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.