cordova-plugin-compat

v1.2.0

[DEPRECATED] This repo is for remaining backwards compatible with previous versions of Cordova.

Apache-2.0
Latest version published about 3 years ago
    npm install cordova-plugin-compat
  

Package Health Score

51 / 100
  • Popularity
    Recognized
  • Maintenance
    Inactive
  • Security
    No known security issues
  • Community
    Limited

Popularity

Recognized
Weekly Downloads (13,135)
Dependents
28
GitHub Stars
36
Forks
42
Contributors
6

The npm package cordova-plugin-compat receives a total of 13,135 downloads a week. As such, we scored cordova-plugin-compat popularity level to be Recognized.

Based on project statistics from the GitHub repository for the npm package cordova-plugin-compat, we found that it has been starred 36 times, and that 28 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues

Security and license risk for recent versions


Direct Vulnerabilities

1.0.0
1.1.0
1.2.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

1.0.0
1.1.0
1.2.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

1.0.0
1.1.0
1.2.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like cordova-plugin-compat is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test cordova-plugin-compat
Fix it in your project with Snyk!

Maintenance

Inactive
Commit Frequency
No Recent Commits
Open Issues
0
Merged PR
0
Open PR
0
Last Commit
2 years ago

Further analysis of the maintenance status of cordova-plugin-compat based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

An important project maintenance signal to consider for cordova-plugin-compat is that it hasn't seen any new versions released to npm in the past 12 months, and could be considered as a discontinued project, or that which receives low attention from its maintainers.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Community

Limited
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
6
Funding
No
License
Apache-2.0

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like cordova-plugin-compat is missing a Code of Conduct.

Package

Node.js Compatibility
not defined

Age
5 years
Dependencies
0 Direct / 0 Total
Versions
3
Install Size
0 B
Dist-tags
1
# of Files
0
Maintainers
16
TS Typings
No

cordova-plugin-compat has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.