ckeditor5-build-classic-code

v20.0.0

The classic editor build of CKEditor 5 – the best browser-based rich text editor.

GPL-2.0-or-later
Latest version published 11 months ago
    npm install ckeditor5-build-classic-code
  
We couldn't find any similar packages Browse all packages

Package Health Score

45 / 100
Make sure the open source you're using is safe to use
Secure my Project

Popularity

Limited

Weekly Downloads (2)

Dependents
1
GitHub Stars
122
Forks
1.53K
Contributors
20

The npm package ckeditor5-build-classic-code receives a total of 2 downloads a week. As such, we scored ckeditor5-build-classic-code popularity level to be Limited.

Based on project statistics from the GitHub repository for the npm package ckeditor5-build-classic-code, we found that it has been starred 122 times, and that 1 other projects in the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

Security review needed
Powered by Snyk

Security and license risk for significant versions

All Versions

Direct Vulnerabilities

19.0.0
20.0.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

19.0.0
20.0.0

License Risks

19.0.0
20.0.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
All security vulnerabilities belong to production dependencies of direct and indirect packages.

License
GPL-2.0-or-later

Security Policy
No

We found a way for you to contribute to the project! Looks like ckeditor5-build-classic-code is missing a security policy.


You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

    # Install the Snyk CLI and test your project
npm i snyk -g && snyk test ckeditor5-build-classic-code
Fix it in your project with Snyk!

Maintenance

Inactive
archived

Commit Frequency

Open Issues
0
Open PR
2
Last Release
11 months ago
Last Commit
12 months ago

Further analysis of the maintenance status of ckeditor5-build-classic-code based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

We found that ckeditor5-build-classic-code demonstrates a positive version release cadence with at least one new version released in the past 12 months.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Community

Sustainable
Readme.md
Yes
Contributing.md
Yes
Code of Conduct
No
Contributors
20
Funding
No

With more than 10 contributors for the ckeditor5-build-classic-code repository, this is possibly a sign for a growing and inviting community.

We found a way for you to contribute to the project! Looks like ckeditor5-build-classic-code is missing a Code of Conduct.


Embed Package Health Score Badge

package health: 45/100 package health 45/100

Package

Node.js Compatibility
>=8.0.0

Age
11 months
Dependencies
1 Direct
Versions
3
Install Size
5.27 MB
Dist-tags
1
# of Files
66
Maintainers
1
TS Typings
No

ckeditor5-build-classic-code has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.