bootstrap-4-autocomplete

v1.2.3

A simple autocomplete/typeahead for Bootstrap 4 and jQuery

MIT
Latest version published 6 months ago
    npm install bootstrap-4-autocomplete
  

Explore Similar Packages

Package Health Score

53 / 100
  • Popularity
    Limited
  • Maintenance
    Inactive
  • Security
    No known security issues
  • Community
    Limited

Popularity

Limited
Weekly Downloads (131)
Dependents
0
GitHub Stars
26
Forks
12
Contributors
2

The npm package bootstrap-4-autocomplete receives a total of 131 downloads a week. As such, we scored bootstrap-4-autocomplete popularity level to be Limited.

Based on project statistics from the GitHub repository for the npm package bootstrap-4-autocomplete, we found that it has been starred 26 times, and that 0 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues

Security and license risk for recent versions


Direct Vulnerabilities

1.1.0
1.2.0
1.2.1
1.2.2
1.2.3
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

1.1.0
1.2.0
1.2.1
1.2.2
1.2.3
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

1.1.0
1.2.0
1.2.1
1.2.2
1.2.3
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like bootstrap-4-autocomplete is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test bootstrap-4-autocomplete
Fix it in your project with Snyk!

Maintenance

Inactive
Commit Frequency
Open Issues
7
Merged PR
1
Open PR
2
Last Commit
6 months ago

Further analysis of the maintenance status of bootstrap-4-autocomplete based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

We found that bootstrap-4-autocomplete demonstrates a positive version release cadence with at least one new version released in the past 12 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Limited
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
2
Funding
No
License
MIT

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like bootstrap-4-autocomplete is missing a Code of Conduct.

Package

Node.js Compatibility
not defined

Age
1 year
Dependencies
2 Direct / 2 Total
Versions
5
Install Size
15.8 kB
Dist-tags
1
# of Files
8
Maintainers
1
TS Typings
No

We detected a total of 2 direct & transitive dependencies for bootstrap-4-autocomplete. See the full dependency tree of bootstrap-4-autocomplete

bootstrap-4-autocomplete has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.