bitski-provider

v0.10.8

Core Bitski provider

MIT
Latest version published 8 months ago
    npm install bitski-provider
  
We couldn't find any similar packages Browse all packages

Package Health Score

49 / 100
  • Popularity
    Limited
  • Maintenance
    Sustainable
  • Security
    Security review needed
  • Community
    Limited

Popularity

Limited
Weekly Downloads (522)
Dependents
12
GitHub Stars
27
Forks
1
Contributors
3

The npm package bitski-provider receives a total of 522 downloads a week. As such, we scored bitski-provider popularity level to be Limited.

Based on project statistics from the GitHub repository for the npm package bitski-provider, we found that it has been starred 27 times, and that 12 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

Security review needed

Security and license risk for recent versions


Direct Vulnerabilities

0.10.4
0.10.5
0.10.6
0.10.8
0.11.0-beta.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

0.10.4
0.10.5
0.10.6
0.10.8
0.11.0-beta.0

License Risks

0.10.4
0.10.5
0.10.6
0.10.8
0.11.0-beta.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Snyk detected that the latest version of bitski-provider has a security vulnerability.

We highly advise you to review these security issues.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like bitski-provider is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test bitski-provider
Fix it in your project with Snyk!

Maintenance

Sustainable
Commit Frequency
Open Issues
0
Merged PR
162
Open PR
2
Last Commit
1 month ago

Further analysis of the maintenance status of bitski-provider based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Sustainable.

We found that bitski-provider demonstrates a positive version release cadence with at least one new version released in the past 12 months.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Community

Limited
Readme.md
No
Contributing.md
No
Code of Conduct
No
Contributors
3
Funding
No
License
MIT

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like bitski-provider is missing a Code of Conduct.

Package

Node.js Compatibility
not defined

Age
2 years
Dependencies
4 Direct / 39 Total
Versions
6
Install Size
417 kB
Dist-tags
3
# of Files
107
Maintainers
3
TS Typings
No

We detected a total of 39 direct & transitive dependencies for bitski-provider. See the full dependency tree of bitski-provider

bitski-provider has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.