babel-plugin-lodash

v3.3.4

Modular Lodash builds without the hassle.

MIT
Latest version published over 2 years ago
    npm install babel-plugin-lodash
  

Explore Similar Packages

Package Health Score

67 / 100
  • Popularity
    Popular
  • Maintenance
    Inactive
  • Security
    No known security issues
  • Community
    Sustainable

Popularity

Popular
Weekly Downloads (816,388)
Dependents
4.22K
GitHub Stars
1.8K
Forks
89
Contributors
14

The npm package babel-plugin-lodash receives a total of 816,388 downloads a week. As such, we scored babel-plugin-lodash popularity level to be Popular.

Based on project statistics from the GitHub repository for the npm package babel-plugin-lodash, we found that it has been starred 1,799 times, and that 4,221 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues

Security and license risk for recent versions


Direct Vulnerabilities

3.3.0
3.3.1
3.3.2
3.3.3
3.3.4
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

3.3.0
3.3.1
3.3.2
3.3.3
3.3.4
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

3.3.0
3.3.1
3.3.2
3.3.3
3.3.4
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like babel-plugin-lodash is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test babel-plugin-lodash
Fix it in your project with Snyk!

Maintenance

Inactive
Commit Frequency
No Recent Commits
Open Issues
8
Merged PR
67
Open PR
5
Last Commit
2 years ago

Further analysis of the maintenance status of babel-plugin-lodash based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Inactive.

An important project maintenance signal to consider for babel-plugin-lodash is that it hasn't seen any new versions released to npm in the past 12 months, and could be considered as a discontinued project, or that which receives low attention from its maintainers.

In the past month we didn't find any pull request activity or change in issues status has been detected for the GitHub repository.

Community

Sustainable
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
14
Funding
No
License
MIT

With more than 10 contributors for the babel-plugin-lodash repository, this is possibly a sign for a growing and inviting community.

We found a way for you to contribute to the project! Looks like babel-plugin-lodash is missing a Code of Conduct.

Package

Node.js Compatibility
not defined

Age
5 years
Dependencies
5 Direct / 17 Total
Versions
5
Install Size
25.6 kB
Dist-tags
1
# of Files
13
Maintainers
2
TS Typings
No

We detected a total of 17 direct & transitive dependencies for babel-plugin-lodash. See the full dependency tree of babel-plugin-lodash

babel-plugin-lodash has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.