@lerna/bootstrap

v3.21.0

Link local packages together and install remaining package dependencies

MIT
Latest version published 6 months ago
    npm install @lerna/bootstrap
  

Explore Similar Packages

Package Health Score

79 / 100
  • Popularity
    Key ecosystem project
  • Maintenance
    Sustainable
  • Security
    Security review needed
  • Community
    Active

Popularity

Key ecosystem project
Weekly Downloads (1,006,232)
Dependents
4.61K
GitHub Stars
25.13K
Forks
1.61K
Contributors
250

The npm package @lerna/bootstrap receives a total of 1,006,232 downloads a week. As such, we scored @lerna/bootstrap popularity level to be Key ecosystem project.

Based on project statistics from the GitHub repository for the npm package @lerna/bootstrap, we found that it has been starred 25,126 times, and that 4,605 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

Security review needed

Security and license risk for recent versions


Direct Vulnerabilities

3.18.0
3.18.4
3.18.5
3.20.0
3.21.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

3.18.0
3.18.4
3.18.5
3.20.0
3.21.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

3.18.0
3.18.4
3.18.5
3.20.0
3.21.0
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Snyk detected that the latest version of @lerna/bootstrap has a security vulnerability.

We highly advise you to review these security issues.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like @lerna/bootstrap is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test @lerna/bootstrap
Fix it in your project with Snyk!

Maintenance

Sustainable
Commit Frequency
Open Issues
486
Merged PR
579
Open PR
42
Last Commit
5 months ago

Further analysis of the maintenance status of @lerna/bootstrap based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Sustainable.

We found that @lerna/bootstrap demonstrates a positive version release cadence with at least one new version released in the past 12 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Active
Readme.md
Yes
Contributing.md
No
Code of Conduct
Yes
Contributors
250
Funding
No
License
MIT

A good and healthy external contribution signal for @lerna/bootstrap project, which invites more than one hundred open source maintainers to collaborate on the repository.

Package

Node.js Compatibility
>= 6.9.0

Age
3 years
Dependencies
23 Direct / 367 Total
Versions
5
Install Size
53.5 kB
Dist-tags
1
# of Files
8
Maintainers
2
TS Typings
No

We detected a total of 367 direct & transitive dependencies for @lerna/bootstrap. See the full dependency tree of @lerna/bootstrap

@lerna/bootstrap has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.