@apidevtools/swagger-parser

v10.1.0

Swagger 2.0 and OpenAPI 3.0 parser and validator for Node and browsers

MIT
Latest version published 5 days ago
    npm install @apidevtools/swagger-parser
  

Package Health Score

86 / 100

Security

No known security issues
Powered by Snyk
All security vulnerabilities belong to production dependencies of direct and indirect packages.

Security and license risk for significant versions

All Versions
Version Vulnerabilities License Risk
10.1.0 | 05/2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
10.0.3 | 08/2021
Popular
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
9.0.1 | 03/2020
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
8.0.4 | 03/2020
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
License
MIT
Security Policy
No

Is your project affected by vulnerabilities?

Scan your projects for vulnerabilities. Fix quickly with automated fixes. Get started with Snyk for free.

# Install the Snyk CLI and test your project
npm i snyk -g && snyk test @apidevtools/swagger-parser
Get started free

Popularity

Popular

Weekly Downloads (492,657)

Download trend
Dependents
70
GitHub Stars
860
Forks
133
Contributors
30

Direct Usage Popularity

TOP 30%

The npm package @apidevtools/swagger-parser receives a total of 492,657 downloads a week. As such, we scored @apidevtools/swagger-parser popularity level to be Popular.

Based on project statistics from the GitHub repository for the npm package @apidevtools/swagger-parser, we found that it has been starred 860 times, and that 70 other projects in the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Community

Sustainable
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
30
Funding
Yes

With more than 10 contributors for the @apidevtools/swagger-parser repository, this is possibly a sign for a growing and inviting community.

We found a way for you to contribute to the project! Looks like @apidevtools/swagger-parser is missing a Code of Conduct.


Embed Package Health Score Badge

package health: 86/100 package health 86/100

Maintenance

Healthy

Commit Frequency

Open Issues
56
Open PR
6
Last Release
5 days ago
Last Commit
5 days ago

Further analysis of the maintenance status of @apidevtools/swagger-parser based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Healthy.

We found that @apidevtools/swagger-parser demonstrates a positive version release cadence with at least one new version released in the past 3 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Package

Node.js Compatibility
not defined

Age
2 years
Dependencies
7 Direct
Versions
9
Install Size
79.2 kB
Dist-tags
1
# of Files
10
Maintainers
3
TS Typings
Yes

@apidevtools/swagger-parser has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.