@amcharts/amcharts4

v4.10.9

amCharts 4

SEE LICENSE IN LICENSE
Latest version published 7 days ago
    npm install @amcharts/amcharts4
  
We couldn't find any similar packages Browse all packages

Package Health Score

75 / 100
  • Popularity
    Recognized
  • Maintenance
    Healthy
  • Security
    No known security issues
  • Community
    Sustainable

Popularity

Recognized
Weekly Downloads (53,511)
Dependents
78
GitHub Stars
819
Forks
242
Contributors
6

The npm package @amcharts/amcharts4 receives a total of 53,511 downloads a week. As such, we scored @amcharts/amcharts4 popularity level to be Recognized.

Based on project statistics from the GitHub repository for the npm package @amcharts/amcharts4, we found that it has been starred 819 times, and that 78 other projects on the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues

Security and license risk for recent versions


Direct Vulnerabilities

4.10.5
4.10.6
4.10.7
4.10.8
4.10.9
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

4.10.5
4.10.6
4.10.7
4.10.8
4.10.9
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

License Risks

4.10.5
4.10.6
4.10.7
4.10.8
4.10.9
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L
  • 0
    H
  • 0
    M
  • 0
    L

Security Policy
No
All security vulnerabilities belong to production dependencies of direct and indirect packages.

You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

We found a way for you to contribute to the project! Looks like @amcharts/amcharts4 is missing a security policy.

    # Install the Snyk CLI and test your project
npm i snyk && snyk test @amcharts/amcharts4
Fix it in your project with Snyk!

Maintenance

Healthy
Commit Frequency
Open Issues
67
Merged PR
2
Open PR
3
Last Commit
7 days ago

Further analysis of the maintenance status of @amcharts/amcharts4 based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Healthy.

We found that @amcharts/amcharts4 demonstrates a positive version release cadence with at least one new version released in the past 3 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Sustainable
Readme.md
Yes
Contributing.md
No
Code of Conduct
No
Contributors
6
Funding
No
License
SEE LICENSE IN LICENSE

This project has seen only 10 or less contributors.

We found a way for you to contribute to the project! Looks like @amcharts/amcharts4 is missing a Code of Conduct.

Package

Node.js Compatibility
not defined

Age
3 years
Dependencies
14 Direct / 209 Total
Versions
5
Install Size
22.6 MB
Dist-tags
1
# of Files
3.12K
Maintainers
3
TS Typings
No

We detected a total of 209 direct & transitive dependencies for @amcharts/amcharts4. See the full dependency tree of @amcharts/amcharts4

@amcharts/amcharts4 has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.