glibc vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the glibc package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • L
Out-of-bounds Read
* Not available 06 Jan, 2021
  • L
Loop with Unreachable Exit Condition ('Infinite Loop')
* Not available 06 Jan, 2021
  • L
Integer Underflow
* Not available 02 Apr, 2020
  • M
Out-of-bounds Write
<2.27-3ubuntu1.2 Not available 07 Mar, 2020
  • L
Use After Free
<2.27-3ubuntu1.2 Not available 07 Mar, 2020
  • L
Out-of-Bounds
<2.27-3ubuntu1.2 Not available 04 Mar, 2020
  • L
Information Exposure
<2.27-3ubuntu1.2 Not available 20 Nov, 2019
  • L
Out-of-bounds Read
<2.27-3ubuntu1.2 Not available 26 Feb, 2019
  • L
Improper Data Handling
* Not available 26 Feb, 2019
  • L
Improper Input Validation
* Not available 21 Jan, 2019
  • M
Improper Input Validation
<2.27-3ubuntu1.2 Not available 02 Dec, 2018
  • M
Out-of-bounds Write
<2.27-3ubuntu1.2 Not available 18 May, 2018
  • M
Out-of-bounds Write
<2.27-3ubuntu1.2 Not available 18 May, 2018
  • L
Improper Data Handling
* Not available 20 Mar, 2017
  • L
Improper Input Validation
* Not available 02 Mar, 2017