xmlhttprequest-ssl vulnerabilities

XMLHttpRequest for Node

Latest version

2.0.0

First published

6 years ago

Latest version published

a month ago

Licenses detected

  • license: MIT >=0
Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the xmlhttprequest-ssl package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • H
Access Restriction Bypass
<1.6.1 Not available 26 Apr, 2021
  • H
Arbitrary Code Injection
<1.6.2 Not available 05 Mar, 2021
Versions
Version Published Licenses Direct Vulnerabilities
xmlhttprequest-ssl 2.0.0 Latest 17 Jun, 2021 MIT
  • 0 C
  • 0 H
  • 0 M
  • 0 L
xmlhttprequest-ssl 1.6.3 17 May, 2021 MIT
  • 0 C
  • 0 H
  • 0 M
  • 0 L
xmlhttprequest-ssl 1.6.2 04 May, 2021 MIT
  • 0 C
  • 0 H
  • 0 M
  • 0 L
xmlhttprequest-ssl 1.6.1 19 Apr, 2021 MIT
  • 0 C
  • 1 H
  • 0 M
  • 0 L
xmlhttprequest-ssl 1.6.0 31 Jul, 2019 MIT
  • 0 C
  • 2 H
  • 0 M
  • 0 L
xmlhttprequest-ssl 1.5.5 11 Jan, 2018 MIT
  • 0 C
  • 2 H
  • 0 M
  • 0 L
xmlhttprequest-ssl 1.5.4 26 Sep, 2017 MIT
  • 0 C
  • 2 H
  • 0 M
  • 0 L
xmlhttprequest-ssl 1.5.3 20 Sep, 2016 MIT
  • 0 C
  • 2 H
  • 0 M
  • 0 L
xmlhttprequest-ssl 1.5.2 26 Jan, 2016 MIT
  • 0 C
  • 2 H
  • 0 M
  • 0 L
xmlhttprequest-ssl 1.5.1 27 May, 2015 MIT
  • 0 C
  • 2 H
  • 0 M
  • 0 L