Information Exposure

Affecting serve package, versions <6.5.2

Do your applications use this vulnerable package? Test your applications

Overview

serve is a module provides a neat interface for listing the directory's contents and switching into sub folders.

Affected versions of this package are vulnerable to Information Exposure through directory listing. It allows directory browsing and to serve static files through the browser.

Remediation

Update serve to version 6.5.2 or higher.

References

-HackerOne Report

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N/E:F/RL:O/RC:C
Credit
digitalwizard
CVE
CVE-2018-3718
CWE
CWE-200
Snyk ID
npm:serve:20180318
Disclosed
18 Mar, 2018
Published
18 Mar, 2018