Cross-site Request Forgery (CSRF)

Affecting pym.js package, versions <1.3.2

Do your applications use this vulnerable package? Test your applications

Overview

pym.js embeds and resizes an iframe responsively (width and height) within its parent container.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via the _onNavigateToMessage function. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.

Remediation

Upgrade pym.js to version 1.3.2 or higher.

References

CVSS Score

8.2
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Credit
Unknown
CVE
CVE-2018-1000086
CWE
CWE-352
Snyk ID
npm:pym.js:20180215
Disclosed
14 Feb, 2018
Published
21 Feb, 2018