Arbitrary Code Execution

Affecting nodebb package, versions >=0.4.3 <1.4.1

Do your applications use this vulnerable package? Test your applications

Overview

nodebb is a NodeBB Forum. Affected versions of the package are vulnerable to Arbitrary code execution .

Remediation

Upgrade nodebb to version 1.4.1 or higher.

References

CVSS Score

5.6
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Ben Lubar
CWE
CWE-94
Snyk ID
npm:nodebb:20161120
Disclosed
19 Nov, 2016
Published
03 Apr, 2017