node-uuid vulnerabilities

Rigorous implementation of RFC4122 (v1 and v4) UUIDs.

Latest version 1.4.8
First published 8 years ago
Latest version published 2 years ago

Licenses detected

  • license: Unknown >=1.0.0 <1.4.2
  • license: MIT >=1.4.2
Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the node-uuid package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • M
Denial of Service (DoS)
<1.3.1 Not available 23 Nov, 2016
  • M
Insecure Randomness
<1.4.4 Available 28 Mar, 2016
Versions
Version Published Licenses Direct Vulnerabilities
node-uuid 1.4.8 Deprecated Latest 22 Mar, 2017 MIT
  • 0 H
  • 0 M
  • 0 L
node-uuid 1.4.7 Deprecated 13 Nov, 2015 MIT
  • 0 H
  • 0 M
  • 0 L
node-uuid 1.4.6 Deprecated 12 Nov, 2015 MIT
  • 0 H
  • 0 M
  • 0 L
node-uuid 1.4.3 Deprecated 05 Mar, 2015 MIT
  • 0 H
  • 1 M
  • 0 L
node-uuid 1.4.2 Deprecated 03 Dec, 2014 MIT
  • 0 H
  • 1 M
  • 0 L
node-uuid 1.4.1 Deprecated 17 Aug, 2013 Unknown
  • 0 H
  • 1 M
  • 0 L
node-uuid 1.4.0 Deprecated 18 Oct, 2012 Unknown
  • 0 H
  • 1 M
  • 0 L
node-uuid 1.2.0 Deprecated 06 Feb, 2012 Unknown
  • 0 H
  • 2 M
  • 0 L
node-uuid 1.0.0 Deprecated 06 Feb, 2012 Unknown
  • 0 H
  • 2 M
  • 0 L
node-uuid 1.1.0 Deprecated 06 Feb, 2012 Unknown
  • 0 H
  • 2 M
  • 0 L
node-uuid 1.3.2 Deprecated 06 Feb, 2012 Unknown
  • 0 H
  • 1 M
  • 0 L
node-uuid 1.3.1 Deprecated 06 Feb, 2012 Unknown
  • 0 H
  • 1 M
  • 0 L
node-uuid 1.3.0 Deprecated 06 Feb, 2012 Unknown
  • 0 H
  • 2 M
  • 0 L
node-uuid 1.3.3 Deprecated 06 Feb, 2012 Unknown
  • 0 H
  • 1 M
  • 0 L