Information Disclosure

Affecting nforce package, versions <0.6.1

Overview

nforce is a REST API wrapper for force.com, database.com, and salesforce.com. Affected versions of the package leak the client_secret variable.

Remediation

Upgrade nforce to version 0.6.1 or higher.

References

Do your applications use this vulnerable package?

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Credit
Gonzalo Huerta-Canepa
CWE
CWE-200
Snyk ID
npm:nforce:20131218
Disclosed
17 Dec, 2013
Published
08 May, 2017