Arbitrary Code Execution

Affecting mathjs package, versions <3.17.0

Do your applications use this vulnerable package? Test your applications

Overview

mathjs is an extensive math library for JavaScript and Node.js

Affected versions of the package are vulnerable to Arbitrary Code Execution via typed-function. A malicious user could possibly execute arbitrary code in the JavaScript engine, by creating a typed function with JavaScript code in the name.

Remediation

Upgrade mathjs to version 3.17.0 or higher.

References

CVSS Score

7.3
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Credit
Masato Kinugawa
CVE
CVE-2017-1001002
CWE
CWE-94
Snyk ID
npm:mathjs:20171118
Disclosed
18 Nov, 2017
Published
28 Nov, 2017