Cross-site Scripting (XSS)

Affecting kibana package, versions >=5.3.0 <5.3.3 || >=5.4.0 <5.4.1

medium severity

Overview

Kibana is an open source, browser-based analytics and search dashboard for Elasticsearch.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS).

Starting in version 5.3.0, Kibana had a cross-site scripting (XSS) vulnerability in the Discover page that could allow an attacker to obtain sensitive information from or perform destructive actions on behalf of other Kibana users.

Remediation

Upgrade kibana to versions 5.3.3, 5.4.1 or higher.

References

https://discuss.elastic.co/t/elastic-stack-5-4-1-and-5-3-3-security-updates/87952)

Do your applications use this vulnerable package?

Credit
Thomas Goytil
CVE
CVE-2017-8440
CWE
CWE-79
Snyk ID
npm:kibana:20170605
Disclosed
05 Jun, 2017
Published
04 Jan, 2018