CSV Injection

Affecting keystone package, versions <4.0.0-beta.7

Do your applications use this vulnerable package? Test your applications

Overview

keystone is an web Application Framework and Admin GUI / Content Management System built on Express.js and Mongoose.

Affected versions of the package are vulnerable to CSV Injection.

Remediation

Upgrade keystone to version 4.0.0-beta.7 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H/E:P/RL:O/RC:R
Credit
Unknown
CVE
CVE-2017-15879
CWE
CWE-74
Snyk ID
npm:keystone:20170918-2
Disclosed
18 Sep, 2017
Published
05 Nov, 2017