http-file-server vulnerabilities

HTTP file server

Latest version 0.2.6
First published 6 years ago
Latest version published a year ago

Licenses detected

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the http-file-server package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • M
Cross-site Scripting (XSS)
* Not available 24 Jul, 2019
  • H
Path Traversal
* Not available 10 Jul, 2019
Versions
Version Published Licenses Direct Vulnerabilities
http-file-server 0.2.6 Latest 22 May, 2018 GPL-3.0
  • 1 H
  • 1 M
  • 0 L
http-file-server 0.2.5 02 Feb, 2014 GPL-3.0
  • 1 H
  • 1 M
  • 0 L
http-file-server 0.2.4 02 Feb, 2014 GPL-3.0
  • 1 H
  • 1 M
  • 0 L
http-file-server 0.2.3 02 Feb, 2014 GPL-3.0
  • 1 H
  • 1 M
  • 0 L
http-file-server 0.2.2 02 Feb, 2014 GPL-3.0
  • 1 H
  • 1 M
  • 0 L
http-file-server 0.2.1 10 Dec, 2013 GPL-3.0
  • 1 H
  • 1 M
  • 0 L
http-file-server 0.2.0 10 Dec, 2013 GPL-3.0
  • 1 H
  • 1 M
  • 0 L
http-file-server 0.1.0 07 Dec, 2013 GPL-3.0
  • 1 H
  • 1 M
  • 0 L