Open Redirect

Affecting ghost package, versions <0.10.0

Do your applications use this vulnerable package? Test your applications

Overview

ghost is a blogging platform. Affected versions of the package are vulnerable to Open Redirect attacks. A malicious user can create a link containing double slashes, which are treated as HTTP calls, and redirect to a site of their choosing.

Remediation

Upgrade ghost to version 0.10.0 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Jesse Dijkstra
CWE
CWE-601
Snyk ID
npm:ghost:20160823
Disclosed
22 Aug, 2016
Published
30 May, 2017