Authentication Bypass

Affecting ghost package, versions <0.5.9

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

ghost is a blogging platform. Affected versions of the package are vulnerable to Authentication Bypass via Privilege Reduction. An attacker can change the privileges of other users, and update their email.

Remediation

Upgrade ghost to version 0.5.9 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Matteo Beccaro
CVE
CVE-2015-1408
CWE
CWE-285
Snyk ID
npm:ghost:20150303-3
Disclosed
02 Mar, 2015
Published
30 May, 2017