Resources Downloaded over Insecure Protocol

Affecting gatsby-cli package, versions <1.0.9

Do your applications use this vulnerable package? Test your applications

Overview

gatsby-cli is a command-line interface for creating new sites and running Gatsby commands.

Affected versions of the package are vulnerable to Resources Downloaded over Insecure Protocol due to downloading resources over an insecure protocol. It used the git:// protocol to clone repositories, which isn't safe as it is unencrypted. You can read more about Man-in-the-Middle (MitM) on our blog.

Remediation

Upgrade gatsby-cli to version 1.0.9 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
davidjb
CWE
CWE-300
Snyk ID
npm:gatsby-cli:20170202
Disclosed
01 Feb, 2017
Published
01 Mar, 2018