Arbitrary Code Execution

Affecting electron package, versions >=1.7.0 <1.7.13 || >=1.8.1 <1.8.4 || >=2.0.0-beta.1 <2.0.0-beta.4

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Arbitrary Code Execution. It contains an improper handling of values vulnerability in Webviews. This attack appear to be exploitable via an app which allows execution of 3rd party code AND disallows node integration AND has not specified if webview is enabled/disabled.

Remediation

Upgrade electron to version 1.7.13, 1.8.4, 2.0.0-beta.4 or higher.

References

CVSS Score

8.1
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Unknown
CVE
CVE-2018-1000136
CWE
CWE-228
Snyk ID
npm:electron:20180323
Disclosed
23 Mar, 2018
Published
27 Mar, 2018