Arbitrary execution

Affecting cordova-ios package, versions >=3.5.0 <4.0.0

Do your applications use this vulnerable package? Test your applications

Overview

cordova-ios is an iOS application library that allows for Cordova-based projects to be built for the iOS Platform.

Affected versions of the package are vulnerable to Arbitrary Code Execution. A malicious plugin can be executed when a user clicks on a link.

Remediation

Upgrade cordova-ios to version 4.0.0 or higher.

References

CVSS Score

6.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Credit
Ian Clelland
CVE
CVE-2015-5208
CWE
CWE-20
Snyk ID
npm:cordova-ios:20141024
Disclosed
23 Oct, 2014
Published
21 Jun, 2017