Arbitrary Command Execution

Affecting angular package, versions <1.3.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

angular is a package that lets you write client-side web applications as if you had a smarter browser. It also lets you use HTML as your template language and lets you extend HTML’s syntax to express your application’s components clearly and succinctly.

Affected versions of this package are vulnerable to Arbitrary Command Execution due to the assignment functions accessing constructors functions, allowing attackers to execute their malicious code.

Remediation

Upgrade angular to version 1.3.2 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:L
Credit
Sebastian Lekies, Jann Horn, Gábor Molnár
CWE
CWE-78
Snyk ID
npm:angular:20141104
Disclosed
03 Nov, 2014
Published
23 Jan, 2017