Sensitive Information Exposure

Affecting airbrake package, versions <=0.3.8

Do your applications use this vulnerable package? Test your applications

Overview

airbrake is a Node.js notifier for the Airbrake bug and error tracking service. Versions prior to 0.4.0 serialized all environment variables and could lead to sensitive information exposure.

Remediation

Upgrade airbrake version 0.4.0 or greater.

References

CVSS Score

5.9
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
Credit
Hrvoje Šimić
CWE
CWE-200
Snyk ID
npm:airbrake:20160215
Disclosed
15 Feb, 2016
Published
10 Oct, 2016