org.apache.activemq:activemq-client vulnerabilities

The ActiveMQ Client implementation

Latest version: 5.15.10

Licenses detected

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the org.apache.activemq:activemq-client package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • M
Denial of Service (DoS)
[5.0.0, 5.14.5) Not available 04 Jul, 2019
  • M
Denial of Service (DoS)
[5.0.0,5.15.9) Not available 28 Mar, 2019
  • H
Man-in-the-Middle (MitM)
[5.0.0,5.15.6) Not available 10 Sep, 2018
  • H
Arbitrary Code Execution
[,5.11.3),[5.12.0, 5.12.2) Not available 09 Dec, 2015
  • H
XML External Entity (XXE) Injection
[5,5.10.1) Not available 19 Oct, 2015
  • M
Cross-site Scripting (XSS)
[4.0.0,5.9.0) Not available 08 Jun, 2014