wget vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the wget package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • H
RHSA-2019:1228
centos:7: <0:1.14-18.el7_6.1 Not available 15 May, 2019
  • L
CVE-2019-5953
debian:10: <1.20.1-1.1,debian:8: <1.16-1+deb8u6,debian:9: <1.18-5+deb9u3,debian:unstable: <1.20.1-1.1,ubuntu:12.04: <1.13.4-2ubuntu1.7,ubuntu:14.04: <1.15-1ubuntu1.14.04.5,ubuntu:16.04: <1.17.1-1ubuntu1.5,ubuntu:18.04: <1.19.4-1ubuntu2.2,ubuntu:18.10: <1.19.5-1ubuntu1.1 Not available 05 Apr, 2019
  • M
RHSA-2018:3052
centos:7: <0:1.14-18.el7 Not available 29 Jan, 2019
  • M
ELSA-2018-3052
oracle:7: <0:1.14-18.el7 Not available 29 Jan, 2019
  • L
CVE-2018-20483
alpine:3.6: <1.20.1-r0,alpine:3.7: <1.20.1-r0,alpine:3.8: <1.20.1-r0,alpine:3.9: <1.20.1-r0,debian:10: <1.20.1-1,debian:unstable: <1.20.1-1,ubuntu:18.04: <1.19.4-1ubuntu2.2,ubuntu:18.10: <1.19.5-1ubuntu1.1 Not available 26 Dec, 2018
  • L
RHSA-2014:0151
centos:6: <0:1.12-1.11.el6_5 Not available 27 Jun, 2018
  • M
ELSA-2014-1764
oracle:6: <0:1.12-5.el6_6.1,oracle:7: <0:1.14-10.el7_0.1 Not available 27 Jun, 2018
  • M
RHSA-2009:1549
centos:5: <0:1.11.4-2.el5_4.1 Not available 27 Jun, 2018
  • H
ELSA-2017-3075
oracle:7: <0:1.14-15.el7_4.1 Not available 27 Jun, 2018
  • H
RHSA-2017:3075
centos:7: <0:1.14-15.el7_4.1 Not available 27 Jun, 2018
  • M
ELSA-2016-2587
oracle:7: <0:1.14-13.el7 Not available 27 Jun, 2018
  • M
RHSA-2014:1764
centos:6: <0:1.12-5.el6_6.1,centos:7: <0:1.14-10.el7_0.1 Not available 27 Jun, 2018
  • M
RHSA-2016:2587
centos:7: <0:1.14-13.el7 Not available 27 Jun, 2018
  • M
ELSA-2009-1549
oracle:5: <0:1.11.4-2.el5_4.1 Not available 27 Jun, 2018
  • L
ELSA-2014-0151
oracle:6: <0:1.12-1.11.el6_5 Not available 27 Jun, 2018
  • M
Cookie Injection
alpine:3.4: <1.18-r3,alpine:3.5: <1.18-r4,alpine:3.6: <1.19.5-r0,alpine:3.7: <1.19.5-r0,alpine:3.8: <1.19.5-r0,alpine:3.9: <1.19.5-r0,debian:10: <1.19.5-1,debian:8: <1.16-1+deb8u5,debian:9: <1.18-5+deb9u2,debian:unstable: <1.19.5-1,ubuntu:12.04: <1.13.4-2ubuntu1.6,ubuntu:14.04: <1.15-1ubuntu1.14.04.4,ubuntu:16.04: <1.17.1-1ubuntu1.4,ubuntu:17.10: <1.19.1-3ubuntu1.2,ubuntu:18.04: <1.19.4-1ubuntu2.1 Not available 06 May, 2018
  • L
Improper Restriction of Operations within the Bounds of a Memory Buffer
alpine:3.4: <1.18-r2,alpine:3.5: <1.18-r3,alpine:3.6: <1.19.2-r0,alpine:3.7: <1.19.2-r0,alpine:3.8: <1.19.2-r0,alpine:3.9: <1.19.2-r0,debian:10: <1.19.2-1,debian:8: <1.16-1+deb8u4,debian:9: <1.18-5+deb9u1,debian:unstable: <1.19.2-1,ubuntu:12.04: <1.13.4-2ubuntu1.5,ubuntu:14.04: <1.15-1ubuntu1.14.04.3,ubuntu:16.04: <1.17.1-1ubuntu1.3,ubuntu:17.04: <1.18-2ubuntu1.1,ubuntu:17.10: <1.19.1-3ubuntu1.1 Not available 27 Oct, 2017
  • M
Improper Restriction of Operations within the Bounds of a Memory Buffer
alpine:3.4: <1.18-r2,alpine:3.5: <1.18-r3,alpine:3.6: <1.19.2-r0,debian:10: <1.19.2-1,debian:8: <1.16-1+deb8u4,debian:9: <1.18-5+deb9u1,debian:unstable: <1.19.2-1,ubuntu:12.04: <1.13.4-2ubuntu1.5,ubuntu:14.04: <1.15-1ubuntu1.14.04.3,ubuntu:16.04: <1.17.1-1ubuntu1.3,ubuntu:17.04: <1.18-2ubuntu1.1,ubuntu:17.10: <1.19.1-3ubuntu1.1 Not available 27 Oct, 2017
  • M
CRLF Injection
alpine:3.3: <1.17.1-r2,alpine:3.4: <1.18-r1,alpine:3.5: <1.18.-r2,alpine:3.6: <1.19.1-r1,alpine:3.7: <1.19.1-r1,alpine:3.8: <1.19.1-r1,alpine:3.9: <1.19.1-r1,debian:10: <1.18-5,debian:8: <1.16-1+deb8u2,debian:9: <1.18-5,debian:unstable: <1.19.1-2,ubuntu:12.04: <1.13.4-2ubuntu1.5,ubuntu:14.04: <1.15-1ubuntu1.14.04.3,ubuntu:16.04: <1.17.1-1ubuntu1.3,ubuntu:17.04: <1.18-2ubuntu1.1,ubuntu:17.10: <1.19.1-3ubuntu1.1 Not available 07 Mar, 2017
  • L
Access Restriction Bypass
debian:10: <1.18-4,debian:8: *,debian:9: <1.18-4,debian:unstable: <1.18-4,ubuntu:12.04: <1.13.4-2ubuntu1.5,ubuntu:14.04: <1.15-1ubuntu1.14.04.3,ubuntu:16.04: <1.17.1-1ubuntu1.3,ubuntu:17.04: <1.18-2ubuntu1.1,ubuntu:17.10: <1.19.1-3ubuntu1.1 Not available 26 Sep, 2016
  • M
Security Features
alpine:3.4: <1.17.1-r1,debian:10: <1.18-1,debian:8: <1.16-1+deb8u1,debian:9: <1.18-1,debian:unstable: <1.18-1,ubuntu:12.04: <1.13.4-2ubuntu1.4,ubuntu:14.04: <1.15-1ubuntu1.14.04.2,ubuntu:15.10: <1.16.1-1ubuntu1.1,ubuntu:16.04: <1.17.1-1ubuntu1.1,ubuntu:16.10: <1.17.1-1ubuntu2,ubuntu:17.04: <1.17.1-1ubuntu2 Not available 30 Jun, 2016
  • M
Directory Traversal
debian:10: <1.16-1,debian:8: <1.16-1,debian:9: <1.16-1,debian:unstable: <1.16-1,ubuntu:12.04: <1.13.4-2ubuntu1.2,ubuntu:14.04: <1.15-1ubuntu1.14.04.1,ubuntu:14.10: <1.15-1ubuntu1.14.10.1 Not available 29 Oct, 2014
  • L
Arbitrary File Overwrite
debian:10: <1.12-2.1,debian:8: <1.12-2.1,debian:9: <1.12-2.1,debian:unstable: <1.12-2.1 Not available 06 Jul, 2010
  • M
Cryptographic Issues
debian:10: <1.12-1,debian:8: <1.12-1,debian:9: <1.12-1,debian:unstable: <1.12-1 Not available 30 Sep, 2009
  • L
Denial of Service (DoS)
debian:10: <1.13-1,debian:8: <1.13-1,debian:9: <1.13-1,debian:unstable: <1.13-1 Not available 23 Dec, 2006
  • M
Arbitrary Code Execution
debian:10: <1.10.2-1,debian:8: <1.10.2-1,debian:9: <1.10.2-1,debian:unstable: <1.10.2-1 Not available 13 Oct, 2005
  • M
Arbitrary Code Execution
debian:10: <1.9.1-11,debian:8: <1.9.1-11,debian:9: <1.9.1-11,debian:unstable: <1.9.1-11 Not available 27 Apr, 2005
  • M
CVE-2004-1487
debian:10: <1.9.1-11,debian:8: <1.9.1-11,debian:9: <1.9.1-11,debian:unstable: <1.9.1-11 Not available 27 Apr, 2005
  • L
Arbitrary File Overwrite
debian:10: <1.9.1-12,debian:8: <1.9.1-12,debian:9: <1.9.1-12,debian:unstable: <1.9.1-12 Not available 31 Dec, 2004
  • H
Buffer Overflow
debian:10: <1.8.2-8,debian:8: <1.8.2-8,debian:9: <1.8.2-8,debian:unstable: <1.8.2-8 Not available 16 Jun, 2003