webkit2gtk vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the webkit2gtk package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • L
CVE-2019-8607
debian:10: *,debian:8: *,debian:9: *,debian:unstable: <2.24.2-1 Not available 18 May, 2019
  • L
CVE-2019-8595
debian:10: *,debian:8: *,debian:9: *,debian:unstable: <2.24.2-1 Not available 18 May, 2019
  • L
CVE-2019-8615
debian:10: *,debian:8: *,debian:9: *,debian:unstable: <2.24.2-1 Not available 18 May, 2019
  • L
CVE-2019-8544
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-8558
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-8536
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-8523
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-7292
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.6-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.6-0ubuntu0.18.10.1 Not available 12 Apr, 2019
  • L
CVE-2019-8551
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-8515
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.6-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.6-0ubuntu0.18.10.1 Not available 12 Apr, 2019
  • L
CVE-2019-6201
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.6-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.6-0ubuntu0.18.10.1 Not available 12 Apr, 2019
  • L
CVE-2019-8506
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-8524
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-7285
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.6-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.6-0ubuntu0.18.10.1 Not available 12 Apr, 2019
  • L
CVE-2019-8535
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-8518
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-8563
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • L
CVE-2019-8503
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.6-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.6-0ubuntu0.18.10.1 Not available 12 Apr, 2019
  • L
CVE-2019-8559
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 12 Apr, 2019
  • M
CWE-19
debian:10: <2.24.1-1,debian:8: *,debian:9: *,debian:unstable: <2.24.1-1,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 10 Apr, 2019
  • H
CWE-119
debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:16.04: *,ubuntu:18.04: <2.24.1-0ubuntu0.18.04.1,ubuntu:18.10: <2.24.1-0ubuntu0.18.10.2 Not available 24 Feb, 2019
  • L
CVE-2019-6212
alpine:3.9: <2.22.7-r0,debian:10: <2.22.6-1,debian:8: *,debian:9: *,debian:unstable: <2.22.6-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.6-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.6-0ubuntu0.18.10.1 Not available 10 Feb, 2019
  • L
CVE-2019-6215
alpine:3.9: <2.22.7-r0,debian:10: <2.22.6-1,debian:8: *,debian:9: *,debian:unstable: <2.22.6-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.6-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.6-0ubuntu0.18.10.1 Not available 10 Feb, 2019
  • L
CVE-2019-6233
debian:10: <2.22.4-1,debian:8: *,debian:9: *,debian:unstable: <2.22.4-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.4-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.4-0ubuntu0.18.10.1 Not available 10 Feb, 2019
  • L
CVE-2019-6227
alpine:3.9: <2.22.7-r0,debian:10: <2.22.5-1,debian:8: *,debian:9: *,debian:unstable: <2.22.5-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.5-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.5-0ubuntu0.18.10.1 Not available 10 Feb, 2019
  • L
CVE-2019-6217
alpine:3.9: <2.22.7-r0,debian:10: <2.22.5-1,debian:8: *,debian:9: *,debian:unstable: <2.22.5-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.5-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.5-0ubuntu0.18.10.1 Not available 10 Feb, 2019
  • L
CVE-2019-6216
alpine:3.9: <2.22.7-r0,debian:10: <2.22.5-1,debian:8: *,debian:9: *,debian:unstable: <2.22.5-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.5-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.5-0ubuntu0.18.10.1 Not available 10 Feb, 2019
  • L
CVE-2019-6234
debian:10: <2.22.4-1,debian:8: *,debian:9: *,debian:unstable: <2.22.4-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.4-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.4-0ubuntu0.18.10.1 Not available 10 Feb, 2019
  • L
CVE-2019-6229
alpine:3.9: <2.22.7-r0,debian:10: <2.22.5-1,debian:8: *,debian:9: *,debian:unstable: <2.22.5-1,ubuntu:16.04: *,ubuntu:18.04: <2.22.5-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.5-0ubuntu0.18.10.1 Not available 10 Feb, 2019
  • L
CVE-2019-6226
debian:10: <2.22.0-2,debian:8: *,debian:9: *,debian:unstable: <2.22.0-2,ubuntu:16.04: *,ubuntu:18.04: <2.22.2-0ubuntu0.18.04.1,ubuntu:18.10: <2.22.0-1 Not available 10 Feb, 2019