openssl vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the openssl package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • M
RHSA-2019:0483
centos:7: <1:1.0.2k-16.el7_6.1 Not available 14 Mar, 2019
  • L
CVE-2019-1543
alpine:3.9: <1.1.1b-r1,debian:10: *,debian:8: *,debian:9: *,debian:unstable: *,ubuntu:18.04: *,ubuntu:18.10: * Not available 06 Mar, 2019
  • M
CVE-2019-1559
debian:10: <1.1.0b-2,debian:8: <1.0.1t-1+deb8u11,debian:9: <1.1.0b-2,debian:unstable: <1.1.0b-2,ubuntu:12.04: *,ubuntu:14.04: *,ubuntu:16.04: <1.0.2g-1ubuntu4.15 Not available 27 Feb, 2019
  • M
ELSA-2018-3221
oracle:7: <1:1.0.2k-16.0.1.el7 Not available 29 Jan, 2019
  • M
RHSA-2018:3221
centos:7: <1:1.0.2k-16.el7 Not available 08 Jan, 2019
  • L
CVE-2018-0734
alpine:3.4: <1.0.2q-r0,alpine:3.5: <1.0.2q-r0,alpine:3.6: <1.0.2q-r0,alpine:3.7: <1.0.2q-r0,alpine:3.8: <1.0.2q-r0,alpine:3.9: <1.1.1a-r0,debian:10: <1.1.1a-1,debian:8: *,debian:9: <1.1.0j-1~deb9u1,debian:unstable: <1.1.1a-1,ubuntu:12.04: *,ubuntu:14.04: <1.0.1f-1ubuntu2.27,ubuntu:16.04: <1.0.2g-1ubuntu4.14,ubuntu:18.04: <1.1.0g-2ubuntu4.3,ubuntu:18.10: <1.1.1-1ubuntu2.1 Not available 02 Dec, 2018
  • L
CVE-2018-0735
alpine:3.9: <1.1.1a-r0,debian:10: <1.1.1a-1,debian:8: <1.0.1t-1+deb8u10,debian:9: <1.1.0j-1~deb9u1,debian:unstable: <1.1.1a-1,ubuntu:18.04: <1.1.0g-2ubuntu4.3,ubuntu:18.10: <1.1.1-1ubuntu2.1 Not available 02 Dec, 2018
  • L
CVE-2018-5407
alpine:3.4: <1.0.2q-r0,alpine:3.5: <1.0.2q-r0,alpine:3.6: <1.0.2q-r0,alpine:3.7: <1.0.2q-r0,alpine:3.8: <1.0.2q-r0,debian:10: <1.1.1~~pre9-1,debian:8: <1.0.1t-1+deb8u10,debian:9: <1.1.0j-1~deb9u1,debian:unstable: <1.1.1~~pre9-1,ubuntu:14.04: <1.0.1f-1ubuntu2.27,ubuntu:16.04: <1.0.2g-1ubuntu4.14,ubuntu:18.04: <1.1.0g-2ubuntu4.3 Not available 02 Dec, 2018
  • M
RHSA-2018:3221
centos:7: <1:1.0.2k-16.el7 Not available 02 Dec, 2018
  • H
ELSA-2018-4248
oracle:6: <0:1.0.1e-57.0.6.el6 Not available 15 Oct, 2018
  • H
ELSA-2018-4249
oracle:7: <1:1.0.2k-12.0.3.el7 Not available 15 Oct, 2018
  • H
ELSA-2018-4228
oracle:6: <0:1.0.1e-57.0.5.el6 Not available 09 Oct, 2018
  • H
RHSA-2007:0964
centos:5: <0:0.9.8b-8.3.el5_0.2 Not available 27 Jun, 2018
  • H
RHSA-2014:0015
centos:6: <0:1.0.1e-16.el6_5.4 Not available 27 Jun, 2018
  • M
RHSA-2012:0059
centos:6: <0:1.0.0-20.el6_2.1 Not available 27 Jun, 2018
  • H
RHSA-2009:0004
centos:5: <0:0.9.8b-10.el5_2.1 Not available 27 Jun, 2018
  • H
RHSA-2014:0376
centos:6: <0:1.0.1e-16.el6_5.7 Not available 27 Jun, 2018
  • H
RHSA-2016:1137
centos:5: <0:0.9.8e-40.el5_11 Not available 27 Jun, 2018
  • H
RHSA-2014:0625
centos:6: <0:1.0.1e-16.el6_5.14 Not available 27 Jun, 2018
  • M
RHSA-2015:1197
centos:5: <0:0.9.8e-36.el5_11 Not available 27 Jun, 2018
  • H
ELSA-2014-0015
oracle:6: <0:1.0.1e-16.el6_5.4 Not available 27 Jun, 2018
  • M
ELSA-2015-1197
oracle:5: <0:0.9.8e-36.0.1.el5_11 Not available 27 Jun, 2018
  • H
ELSA-2016-1137
oracle:5: <0:0.9.8e-40.0.1.el5_11 Not available 27 Jun, 2018
  • M
ELSA-2015-2616
oracle:5: <0:0.9.8e-37.0.1.el5_11 Not available 27 Jun, 2018
  • H
ELSA-2012-0518
oracle:5: <0:0.9.8e-22.el5_8.3,oracle:6: <0:1.0.0-20.el6_2.4 Not available 27 Jun, 2018
  • M
ELSA-2013-0587
oracle:5: <0:0.9.8e-26.el5_9.1,oracle:6: <0:1.0.0-27.el6_4.2 Not available 27 Jun, 2018
  • M
ELSA-2010-0979
oracle:6: <0:1.0.0-4.el6_0.2 Not available 27 Jun, 2018
  • H
ELSA-2016-0722
oracle:7: <1:1.0.1e-51.el7_2.5 Not available 27 Jun, 2018
  • M
ELSA-2016-0008
oracle:6: <0:1.0.1e-42.el6_7.2,oracle:7: <1:1.0.1e-51.el7_2.2 Not available 27 Jun, 2018
  • H
ELSA-2014-0376
oracle:6: <0:1.0.1e-16.el6_5.7 Not available 27 Jun, 2018