openssl vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the openssl package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • M
Integer Overflow or Wraparound
<1.1.0l-1~deb9u3 Not available 17 Feb, 2021
  • H
Integer Overflow or Wraparound
<1.1.0l-1~deb9u3 Not available 17 Feb, 2021
  • L
Inadequate Encryption Strength
<1.0.0d-1 Not available 17 Feb, 2021
  • M
NULL Pointer Dereference
<1.1.0l-1~deb9u2 Not available 09 Dec, 2020
  • L
Inadequate Encryption Strength
<1.1.0c-1 Not available 10 Sep, 2020
  • L
Information Exposure
* Not available 06 Dec, 2019
  • L
Missing Encryption of Sensitive Data
<1.1.0l-1~deb9u1 Not available 11 Sep, 2019
  • M
Missing Encryption of Sensitive Data
<1.1.0l-1~deb9u1 Not available 11 Sep, 2019
  • H
Cryptographic Issues
<1.1.0k-1~deb9u1 Not available 06 Mar, 2019
  • M
Information Exposure
<1.1.0b-2 Not available 27 Feb, 2019
  • M
Use of a Broken or Risky Cryptographic Algorithm
<1.1.0j-1~deb9u1 Not available 02 Dec, 2018
  • M
Use of a Broken or Risky Cryptographic Algorithm
<1.1.0j-1~deb9u1 Not available 02 Dec, 2018
  • M
Information Exposure
<1.1.0j-1~deb9u1 Not available 02 Dec, 2018
  • M
Key Management Errors
<1.0.2a-1 Not available 27 Jun, 2018
  • H
Key Management Errors
<1.1.0j-1~deb9u1 Not available 12 Jun, 2018
  • M
Use of a Broken or Risky Cryptographic Algorithm
<1.1.0j-1~deb9u1 Not available 16 Apr, 2018
  • M
Improper Input Validation
<1.1.0f-3+deb9u2 Not available 27 Mar, 2018
  • M
Uncontrolled Recursion
<1.1.0f-3+deb9u2 Not available 27 Mar, 2018
  • M
Out-of-bounds Read
<1.1.0b-2 Not available 07 Dec, 2017
  • M
Information Exposure
<1.1.0f-3+deb9u2 Not available 07 Dec, 2017
  • H
Resource Exhaustion
<1.0.2j-1 Not available 13 Nov, 2017
  • M
Information Exposure
<1.1.0f-3+deb9u1 Not available 02 Nov, 2017
  • M
Out-of-Bounds
<1.1.0f-3+deb9u1 Not available 28 Aug, 2017
  • L
Key Management Errors
<1.1.0c-1 Not available 04 May, 2017
  • H
Improper Input Validation
<1.1.0e-1 Not available 04 May, 2017
  • H
NULL Pointer Dereference
<1.1.0d-1 Not available 04 May, 2017
  • H
Improper Access Control
<1.1.0c-1 Not available 04 May, 2017
  • M
Information Exposure
<1.1.0d-1 Not available 04 May, 2017
  • H
NULL Pointer Dereference
<1.1.0c-1 Not available 04 May, 2017
  • H
Out-of-bounds Read
<1.1.0d-1 Not available 04 May, 2017