libx11 vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the libx11 package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • H
Integer Overflow or Wraparound
<2:1.6.4-3+deb9u3 Not available 26 Aug, 2020
  • M
Integer Overflow or Wraparound
<2:1.6.4-3+deb9u2 Not available 31 Jul, 2020
  • H
Improper Input Validation
<2:1.6.4-3+deb9u1 Not available 25 Sep, 2018
  • H
Out-of-bounds Write
<2:1.6.4-3+deb9u1 Not available 25 Sep, 2018
  • H
Off-by-one Error
<2:1.6.4-3+deb9u1 Not available 25 Sep, 2018
  • L
Access Restriction Bypass
<2:1.6.4-1 Not available 13 Dec, 2016
  • L
Out-of-bounds Write
<2:1.6.4-1 Not available 13 Dec, 2016
  • H
Numeric Errors
<2:1.6.0-1 Not available 16 Apr, 2015
  • M
Out-of-Bounds
<2:1.5.0-1+deb7u1 Not available 15 Jun, 2013
  • M
Out-of-Bounds
<2:1.5.0-1+deb7u1 Not available 15 Jun, 2013
  • M
Numeric Errors
<2:1.5.0-1+deb7u1 Not available 15 Jun, 2013
  • M
Numeric Errors
<2:1.0.3-7 Not available 24 Mar, 2007
  • L
CVE-2006-5397
<2:1.0.3-3 Not available 03 Nov, 2006
  • L
CVE-2006-4447
<2:1.0.0-7 Not available 30 Aug, 2006