gnupg2 vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the gnupg2 package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • L
Use of a Broken or Risky Cryptographic Algorithm
* Not available 25 Nov, 2019
  • H
Cross-site Request Forgery (CSRF)
* Not available 20 Dec, 2018
  • M
Use After Free
<2.0.26-5 Not available 27 Jun, 2018
  • M
Improper Input Validation
<2.0.26-5 Not available 27 Jun, 2018
  • H
Use of Incorrectly-Resolved Name or Reference
<2.1.18-8~deb9u2 Not available 08 Jun, 2018
  • L
Key Management Errors
* Not available 04 Apr, 2018
  • M
Improper Input Validation
<2.0.24-1 Not available 25 Jun, 2014
  • M
Improper Input Validation
<2.0.22-1 Not available 28 Oct, 2013
  • L
Cryptographic Issues
<2.0.22-1 Not available 10 Oct, 2013
  • M
Improper Input Validation
<2.0.19-2 Not available 24 Jan, 2013
  • M
Resource Management Errors
<2.0.14-2 Not available 05 Aug, 2010
  • H
Resource Management Errors
<2.0.9-1 Not available 27 Mar, 2008
  • M
CVE-2007-1263
<2.0.3-1 Not available 06 Mar, 2007
  • H
CVE-2006-6235
<2.0.0-5.2 Not available 07 Dec, 2006
  • M
CVE-2006-6169
<2.0.0-5.1 Not available 29 Nov, 2006
  • M
CVE-2006-3746
<1.9.20-2 Not available 28 Jul, 2006
  • L
Numeric Errors
<1.9.20-1.1 Not available 19 Jun, 2006
  • H
CVE-2005-2023
<1.9.15-1 Not available 17 Jun, 2005