openssl vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the openssl package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • L
Missing Encryption of Sensitive Data
<1.0.1t-1+deb8u12 Not available 11 Sep, 2019
  • M
Missing Encryption of Sensitive Data
<1.0.1t-1+deb8u12 Not available 11 Sep, 2019
  • M
Information Exposure
<1.0.1t-1+deb8u11 Not available 27 Feb, 2019
  • M
Use of a Broken or Risky Cryptographic Algorithm
<1.0.1t-1+deb8u10 Not available 02 Dec, 2018
  • M
Use of a Broken or Risky Cryptographic Algorithm
* Not available 02 Dec, 2018
  • M
Information Exposure
<1.0.1t-1+deb8u10 Not available 02 Dec, 2018
  • L
CVE-2009-5146
<0.9.8k-1 Not available 27 Jun, 2018
  • M
Key Management Errors
<1.0.1t-1+deb8u6 Not available 27 Jun, 2018
  • H
Key Management Errors
<1.0.1t-1+deb8u9 Not available 12 Jun, 2018
  • M
Use of a Broken or Risky Cryptographic Algorithm
<1.0.1t-1+deb8u9 Not available 16 Apr, 2018
  • M
Uncontrolled Recursion
<1.0.1t-1+deb8u8 Not available 27 Mar, 2018
  • H
Resource Exhaustion
<1.0.1t-1+deb8u6 Not available 13 Nov, 2017
  • M
Out-of-Bounds
<1.0.1t-1+deb8u7 Not available 28 Aug, 2017
  • H
Out-of-bounds Read
<1.0.1t-1+deb8u6 Not available 04 May, 2017
  • H
Resource Management Errors
<1.0.1t-1+deb8u4 Not available 26 Sep, 2016
  • M
Out-of-bounds Read
<1.0.1t-1+deb8u4 Not available 26 Sep, 2016
  • H
Improper Input Validation
<1.0.1t-1+deb8u4 Not available 16 Sep, 2016
  • H
Resource Management Errors
<1.0.1t-1+deb8u4 Not available 16 Sep, 2016
  • H
Out-of-bounds Write
<1.0.1t-1+deb8u4 Not available 16 Sep, 2016
  • H
Out-of-bounds Write
<1.0.1t-1+deb8u4 Not available 16 Sep, 2016
  • H
Numeric Errors
<1.0.1t-1+deb8u4 Not available 16 Sep, 2016
  • H
Out-of-bounds Read
<1.0.1t-1+deb8u4 Not available 01 Aug, 2016
  • M
Information Exposure
<1.0.1t-1+deb8u4 Not available 20 Jun, 2016
  • H
Integer Overflow or Wraparound
<1.0.1t-1+deb8u4 Not available 20 Jun, 2016
  • H
Cryptographic Issues
<0.9.6-1 Not available 05 May, 2016
  • H
Numeric Errors
<1.0.1k-3+deb8u5 Not available 05 May, 2016
  • H
Resource Management Errors
<1.0.1k-3+deb8u5 Not available 05 May, 2016
  • H
Numeric Errors
<1.0.1k-3+deb8u5 Not available 05 May, 2016
  • H
Out-of-Bounds
<1.0.1k-3+deb8u5 Not available 05 May, 2016
  • M
Cryptographic Issues
<1.0.1k-3+deb8u5 Not available 05 May, 2016