systemd vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the systemd package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • M
Allocation of Resources Without Limits or Throttling
<241-7~deb10u8 Not available 21 Jul, 2021
  • L
Authentication Bypass
* Not available 12 May, 2021
  • L
Improper Input Validation
* Not available 03 Jun, 2020
  • H
Use After Free
<241-7~deb10u4 Not available 05 Feb, 2020
  • L
Missing Release of Resource after Effective Lifetime
* Not available 21 Jan, 2020
  • M
Improper Access Control
<241-7~deb10u2 Not available 03 Sep, 2019
  • H
Incorrect Privilege Assignment
* Not available 26 Apr, 2019
  • H
Privilege Chaining
* Not available 26 Apr, 2019
  • H
Improper Authorization
<241-3 Not available 09 Apr, 2019
  • M
Out-of-Bounds
<240-6 Not available 19 Feb, 2019
  • H
Allocation of Resources Without Limits or Throttling
<240-4 Not available 11 Jan, 2019
  • H
Allocation of Resources Without Limits or Throttling
<240-4 Not available 11 Jan, 2019
  • L
Out-of-bounds Read
<240-1 Not available 11 Jan, 2019
  • L
Improper Input Validation
<237-1 Not available 03 Jan, 2019
  • H
Deserialization of Untrusted Data
<239-12 Not available 28 Oct, 2018
  • C
Out-of-Bounds
<239-11 Not available 28 Oct, 2018
  • M
Race Condition
<239-11 Not available 28 Oct, 2018
  • M
CVE-2012-1101
<43-1 Not available 27 Jun, 2018
  • M
Race Condition
<234-1 Not available 16 Feb, 2018
  • L
Access Restriction Bypass
<238-1 Not available 13 Feb, 2018
  • L
Link Following
<237-1 Not available 29 Jan, 2018
  • H
Loop with Unreachable Exit Condition ('Infinite Loop')
<235-3 Not available 26 Oct, 2017
  • C
Out-of-Bounds
<229-1 Not available 25 Sep, 2017
  • L
Improper Input Validation
<234-1 Not available 07 Jul, 2017
  • H
Out-of-bounds Write
<233-10 Not available 28 Jun, 2017
  • H
Improper Input Validation
<232-24 Not available 24 May, 2017
  • H
Access Restriction Bypass
<229-1 Not available 23 Jan, 2017
  • M
Improper Input Validation
<231-9 Not available 13 Oct, 2016
  • M
Improper Input Validation
<231-9 Not available 13 Oct, 2016
  • L
Access Restriction Bypass
<215-1 Not available 20 Apr, 2016