openldap vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the openldap package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • H
Reachable Assertion
<2.4.47+dfsg-3+deb10u6 Not available 14 Feb, 2021
  • H
Reachable Assertion
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • H
Access of Resource Using Incompatible Type ('Type Confusion')
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • H
Integer Underflow
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • H
Loop with Unreachable Exit Condition ('Infinite Loop')
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • H
Release of Invalid Pointer or Reference
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • H
CVE-2020-36226
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • H
Double Free
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • H
Out-of-bounds Read
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • H
Reachable Assertion
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • H
Integer Underflow
<2.4.47+dfsg-3+deb10u5 Not available 26 Jan, 2021
  • L
CVE-2020-25710
<2.4.47+dfsg-3+deb10u4 Not available 13 Nov, 2020
  • L
CVE-2020-25709
<2.4.47+dfsg-3+deb10u4 Not available 13 Nov, 2020
  • H
NULL Pointer Dereference
<2.4.47+dfsg-3+deb10u3 Not available 03 Nov, 2020
  • L
Improper Certificate Validation
* Not available 16 Jul, 2020
  • H
Resource Exhaustion
<2.4.47+dfsg-3+deb10u2 Not available 28 Apr, 2020
  • M
Improper Authentication
<2.4.47+dfsg-3+deb10u1 Not available 24 Jul, 2019
  • H
Improper Authentication
<2.4.47+dfsg-3+deb10u1 Not available 24 Jul, 2019
  • L
Out-of-Bounds
* Not available 18 Dec, 2017
  • L
Improper Initialization
* Not available 05 Sep, 2017
  • M
Double Free
<2.4.44+dfsg-5 Not available 29 May, 2017
  • L
Cryptographic Issues
* Not available 07 Dec, 2015
  • M
Improper Input Validation
<2.4.42+dfsg-2 Not available 11 Sep, 2015
  • M
Access Restriction Bypass
<2.4.40-2 Not available 01 Apr, 2015
  • M
CVE-2015-1546
<2.4.40-4 Not available 12 Feb, 2015
  • M
CVE-2015-1545
<2.4.40-4 Not available 12 Feb, 2015
  • L
Numeric Errors
<2.4.39-1.1 Not available 05 Feb, 2014
  • L
Out-of-Bounds
<2.4.31-1 Not available 29 Jun, 2012
  • L
Numeric Errors
<2.4.28-1 Not available 27 Oct, 2011
  • L
Improper Authentication
<2.4.25-1 Not available 20 Mar, 2011