libwebp vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the libwebp package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • C
Use of Uninitialized Resource
<0.6.1-2+deb10u1 Not available 06 May, 2021
  • C
Out-of-bounds Read
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • C
Out-of-bounds Write
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • C
Out-of-bounds Read
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • C
Use After Free
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • C
Out-of-bounds Read
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • C
Out-of-bounds Read
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • H
Improper Input Validation
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • C
Out-of-bounds Read
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • C
Out-of-bounds Write
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • C
Out-of-bounds Read
<0.6.1-2+deb10u1 Not available 05 May, 2021
  • H
Double Free
<0.5.2-1 Not available 23 May, 2019
  • L
Integer Overflow or Wraparound
* Not available 03 Feb, 2017
  • H
Numeric Errors
<0.1.3-3+nmu1 Not available 07 Nov, 2012