bash vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the bash package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • L
Improper Check for Dropped Privileges
* Not available 28 Nov, 2019
  • H
Out-of-Bounds
<4.3-1 Not available 23 Jun, 2019
  • L
Improper Input Validation
<4.4-1 Not available 22 Mar, 2019
  • L
OS Command Injection
<4.4-1 Not available 28 Aug, 2017
  • H
Improper Input Validation
<4.4-3 Not available 27 Mar, 2017
  • M
Use After Free
<4.4-3 Not available 23 Jan, 2017
  • H
Improper Input Validation
<4.4-1 Not available 19 Jan, 2017
  • H
OS Command Injection
<4.3-9.2 Not available 30 Sep, 2014
  • H
Out-of-Bounds
<4.3-9.2 Not available 28 Sep, 2014
  • H
Out-of-Bounds
<4.3-9.2 Not available 28 Sep, 2014
  • H
OS Command Injection
<4.3-9.2 Not available 27 Sep, 2014
  • H
OS Command Injection
<4.3-9.2 Not available 25 Sep, 2014
  • H
OS Command Injection
<4.3-9.1 Not available 24 Sep, 2014
  • L
Out-of-Bounds
<4.2-4 Not available 27 Aug, 2012
  • L
Link Following
<4.0-2 Not available 08 Dec, 2008