Cross-site Scripting (XSS)

Affecting jquery package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream jquery package.

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Remediation

There is no fixed version for Ubuntu:20.04 jquery.

References

CVSS Score

6.1
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F
CVE
CVE-2020-11023
CWE
CWE-79
Snyk ID
SNYK-UBUNTU2004-JQUERY-580853
Disclosed
29 Apr, 2020
Published
30 Apr, 2020