Out-of-bounds Read

Affecting libbsd package, versions <0.9.1-2ubuntu0.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream libbsd package. See Remediation section below for Ubuntu:19.04 relevant versions.

nlist.c in libbsd before 0.10.0 has an out-of-bounds read during a comparison for a symbol name from the string table (strtab).

Remediation

Upgrade Ubuntu:19.04 libbsd to version 0.9.1-2ubuntu0.1 or higher.

References

CVSS Score

9.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVE
CVE-2019-20367
CWE
CWE-125
Snyk ID
SNYK-UBUNTU1904-LIBBSD-541275
Disclosed
08 Jan, 2020
Published
08 Jan, 2020