Improper Input Validation

Affecting nettle package, versions <3.4.1-0ubuntu0.18.04.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream nettle package. See Remediation section below for Ubuntu:18.04 relevant versions.

A flaw was found in the way nettle's RSA decryption functions handled specially crafted ciphertext. An attacker could use this flaw to provide a manipulated ciphertext leading to application crash and denial of service.

Remediation

Upgrade Ubuntu:18.04 nettle to version 3.4.1-0ubuntu0.18.04.1 or higher.

References

CVSS Score

7.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2021-3580
CWE
CWE-20
Snyk ID
SNYK-UBUNTU1804-NETTLE-1303241
Disclosed
05 Aug, 2021
Published
14 Jun, 2021