Out-of-bounds Read

Affecting libonig package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

An issue was discovered in Oniguruma 6.x before 6.9.4_rc2. In the function fetch_interval_quantifier (formerly known as fetch_range_quantifier) in regparse.c, PFETCH is called without checking PEND. This leads to a heap-based buffer over-read.

References

CVSS Score

7.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2019-19204
CWE
CWE-125
Snyk ID
SNYK-UBUNTU1804-LIBONIG-535414
Disclosed
21 Nov, 2019
Published
22 Nov, 2019