Out-of-bounds Write

Affecting libmaxminddb package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Out-of-bounds Write libmaxminddb before 1.4.3 has a heap-based buffer over-read in dump_entry_data_list in maxminddb.c.

Remediation

There is no fixed version for libmaxminddb.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVE
CVE-2020-28241
CWE
CWE-787
Snyk ID
SNYK-UBUNTU1804-LIBMAXMINDDB-1038542
Disclosed
06 Nov, 2020
Published
10 Nov, 2020