NULL Pointer Dereference

Affecting sqlite3 package, versions <3.11.0-1ubuntu1.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream sqlite3 package. See Remediation section below for Ubuntu:16.04 relevant versions.

In SQLite 3.27.2, interleaving reads and writes in a single transaction with an fts5 virtual table will lead to a NULL Pointer Dereference in fts5ChunkIterate in sqlite3.c. This is related to ext/fts5/fts5_hash.c and ext/fts5/fts5_index.c.

Remediation

Upgrade Ubuntu:16.04 sqlite3 to version 3.11.0-1ubuntu1.2 or higher.

References

CVSS Score

7.5
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2019-9937
CWE
CWE-476
Snyk ID
SNYK-UBUNTU1604-SQLITE3-449763
Disclosed
22 Mar, 2019
Published
22 Mar, 2019