Cross-site Scripting (XSS)

Affecting python-django package, versions <1.8.7-1ubuntu5.13

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream python-django package. See Remediation section below for Ubuntu:16.04 relevant versions.

An issue was discovered in Django 2.2 before 2.2.13 and 3.0 before 3.0.7. Query parameters generated by the Django admin ForeignKeyRawIdWidget were not properly URL encoded, leading to a possibility of an XSS attack.

Remediation

Upgrade Ubuntu:16.04 python-django to version 1.8.7-1ubuntu5.13 or higher.

References

CVSS Score

6.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVE
CVE-2020-13596
CWE
CWE-79
Snyk ID
SNYK-UBUNTU1604-PYTHONDJANGO-571010
Disclosed
03 Jun, 2020
Published
03 Jun, 2020